Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Showcase / Son of Sword
- - By lol_o2 Date 2012-08-01 11:03 Edited 2019-11-04 18:45
Since my previous game is done (almost), I could focus on my next project. It's some mix between Eternal Daughter and Golden Sun.
It features some puzzles, explorable world, pixel-art-like graphics, 21 skills (+secret) to interact with specified objects and >60 FPS
Current soundtrack was planned to be somewhat temporary.

The trailer:

Here (pls report if broken)
Parent - - By ml Date 2013-08-24 22:01
Hi lol_o2. Since I first started trying out Gosu, I have tried at intervals to run Son_of_Sword and Bottomless_Mine, as well as Wrath by Spooner. I kept getting a lot of errors, and I was not able to make sense of all of it, so I would work on other things and come back to it later armed each time with a little bit more knowledge than at the previous attempt.

I think I am finally at the point where, with a little bit of guidance, I can probably get these games to work.

My system is Linux (Ubuntu 12.04), which creates some special issues with case sensitivity and possibly with LOAD_PATH as well.

My most recent attempt to load Son of Sword has been more successful than previous attempts. In several places where files are loaded, I added "../" before the folder name ("gfx", "music", etc.), and this has helped to move things along.

I have now come up against something that I'm not sure how to work around, but perhaps you could point me in the right direction...

/SonOfSword/data/scripts/specjal.rb:27:in initialize': Unknown error (RuntimeError)
    from /SonOfSword/data/scripts/specjal.rb:27:in
    from /SonOfSword/data/scripts/specjal.rb:27:in `[]'

I think that this is possibly a case-sensitivity issue, although I am not sure. For reference, here is what spcjal.rb:27 looks like:
    @@images[name.downcase] =$screen, "../gfx/"+name+".png",able)

Any suggestions would be helpful.

Parent - - By Spooner Date 2013-08-24 22:27
I can assure you that Wrath runs fine in Ubuntu (13.04x64) with Ruby 1.9.3 ;)
Parent - - By ml Date 2013-08-24 23:01
I don't suppose there's a quick and easy way to upgrade from Ubuntu 12.04 to 13.04?..... I will look into this....

When I run into difficulties running games, I generally assume that it is probably not an error in the software, but an error in the user (i.e. myself). I have often found this to be the case...
Parent - - By Spooner Date 2013-08-25 00:32
It worked on 12.04 too. The problem is not the OS, but the version of Gosu you are attempting to use (I strongly suspect).
Parent - By ml Date 2013-08-25 03:34
I will try with different versions of Gosu... I'll let you know how it goes...
- - By lol_o2 Date 2012-09-12 18:11
Game is nearly finished. I'm not giving next demo, but here's a video that shows some of features:
Parent - By Dahrkael Date 2012-09-15 19:33
pretty impresive
Parent - - By jlnr (dev) Date 2013-02-24 08:23
I just wanted to come back to say that this trailer is AWESOME. :)
Parent - - By lol_o2 Date 2013-02-24 09:49
Thanks :)
In return I can say that Gosu is AWESOME
Parent - By ExplodingCookie Date 2013-04-17 00:18
I agree!
- - By lol_o2 Date 2012-10-17 19:35
The game seems to be finished. Download here:
I'm waiting for Ashton to be 'Ocrable', so people don't need Ruby to play.
Parent - By Spooner Date 2012-10-17 23:55
You just need me to make an up to date gem release (I guess it would be 0.0.2alpha) from the latest commit @ github, right? I'm surprised you can't ocra/releasy it as it is though, but fair enough.

I keep picking at Ashton, but I'm having some problems getting my improved shader uniform system to work, so I keep putting of another release, sorry.
- By lol_o2 Date 2013-02-09 10:51 Edited 2013-02-09 11:27
And here's a trailer:
- - By lol_o2 Date 2013-02-10 17:42
I've managed to make Ashton 'ocrable'. I just copied some lines from Gosu source to Ashton and it just worked.
So you can download final release of game from first post.
Parent - - By Spooner Date 2013-02-17 15:14
Care to share what the problem and fix was?
Parent - - By lol_o2 Date 2013-02-17 18:43
It was this standard 'no such file to load: ashton' bug. You just compile game with Ocra and this happens when you want to run it. I fixed it somehow by copying these lines from  gosu.rb  to  ashton.rb:
require 'rbconfig'

if defined? RUBY_PLATFORM and
    %w(-win32 win32- mswin mingw32).any? { |s| RUBY_PLATFORM.include? s } then
  ENV['PATH'] = "#{File.dirname(__FILE__)};#{ENV['PATH']}"

BTW, is the current Ashton's GitHub state broken? The textures didn't work when I updated it and now it can't even be installed.
Parent - - By Spooner Date 2013-02-17 19:31
Er, it (0.0.2alpha) should be up to date with github source and work fine. Just checked all the examples and they seem OK to me. Installation seems fine (on Linux, at least).

spooner@fish:~$ gem install ashton --pre
Fetching: opengl-0.8.0.pre1.gem (100%)
Building native extensions.  This could take a while...
Fetching: gosu-0.7.45.gem (100%)
Building native extensions.  This could take a while...
Fetching: ashton-0.0.2alpha.gem (100%)
Building native extensions.  This could take a while...
Successfully installed opengl-0.8.0.pre1
Successfully installed gosu-0.7.45
Successfully installed ashton-0.0.2alpha
3 gems installed

Right, I'll try to fix that ENV['PATH'] issue when I get around to it. Thanks for pointing it out!
Parent - - By lol_o2 Date 2013-02-17 21:15
'ERROR: Failed to build gem native extension'
C:/Ruby/bin/ruby.exe extconf.rb
checking for glVertex3d() in -lopengl32.lib... no
checking for main() in -lopengl32... yes
checking for GL/gl.h... yes
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
extconf.rb:39:in <main>': undefined method <<' for nil:NilClass (NoMethodError)

Is it problem with Windows or some libraries?
Parent - By Spooner Date 2013-02-17 21:28
Think I see the issue. Thanks! Just a dumb problem that I made with how Ruby compiles stuff on different OSes being slightly inconsistent!

The problem you'll face now, however, is that it requires gosu 0.7.46 and that hasn't been released yet (it contains a critical Gosu fix for Linux that Ashton relies on, though strictly, on Windows, it doesn't require this version, but I can't really be picky). *kicks jlnr*
Parent - - By Spooner Date 2013-02-17 21:43
I've pushed Ashton 0.0.3alpha that should work OK with both compiling and Ocraing. Poke me if it doesn't :)
Parent - - By lol_o2 Date 2013-02-18 10:17
Ok, it works :)
I installed the gem successfully
It's correctly Ocrable
But Textures didn't work...

After few tests and tries, I noticed that Y-axis is reversed when reading pixels from Texture, so when you want to read down it returns you value from up. Guess it's unwanted
Parent - - By Spooner Date 2013-02-18 17:15
Right, "Didn't work" wasn't a terribly helpful feedback originally. However, my tests confirm that the coordinates are correct (0,0 at top left) and so consistent with Gosu. Please double-check your code!
Parent - By lol_o2 Date 2013-02-18 18:48
Line before:
color = @masks[[x/768, y/672]][x%768, y%672]
The hero was falling through tiles.

After I resolved what is the problem:
color = @masks[[x/768, y/672]][x%768, 672-y%672]
Works fine.

And by 'didn't work' I've also meant an error that said: undefined method or local variable: render_    (or it was _render)  in texture.rb
It happened after my previous update, but doesn't appear with current version (so it's fixed)
- By lol_o2 Date 2024-05-11 10:41
The game is now on
Up Topic Gosu / Gosu Showcase / Son of Sword

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill