Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Problems with gems
- By ? Date 2009-11-28 14:19
I am a gosu noob :)
I tried to install Rmagick and it worked. But when I start a game (the RMagickIntegration example) I get this error:
I have the same problem (nearly the same error) with chipmunk.
How can I fix this?
- By ippa Date 2009-11-28 15:11
I don't know how to fix your problem, but if ever want to distribute an gosu game/app as a Win32 executable skip rmagick and go for texplay instead ( ).
- By ? Date 2009-11-28 16:00
So I can't compile Rmagick into an .exe? :/
The problem with TexPlay is, that it only offers a few of commands.
Well, I'll see if I can do what I want with them as well.
- By banister Date 2009-11-28 16:19
let me know what other functionality you want TexPlay to support and i'll think about adding them into the next version
- By ? Date 2009-11-29 09:29
Well, I didn't found a good documentation of all functions yet only the post in your blog.
I just found the splice function but not all of its parameters.
I also found DevIL but I couldn't test it because I have problems with installing opengl (I think I'm gonna open another topic :)
- By ? Date 2009-11-29 20:27
Thanks to your help I have the requirements for devil now but I have another problem now:
How can I use the functions? I tried
require 'gosu'
require 'texplay'
require 'devil'
but the constant (module) Devil is still not defined.

PS: I am still searching for a TexPlay-documentation : D
- By banister Date 2009-11-29 21:32

i assume you required rubygems ?

The Devil constant should be at the top-level, but you should also be using require 'devil/gosu' for the gosu functionality. If you type 'gem which devil' and then go into the test/ subdirectory for the devil gem you should find some examples using gosu/devil together.

TexPlay documentation can be found here      
Admittedly the documentation is presented in quite a wordy/tutorial form but it is nonetheless about 90% complete :)
- By Wurstinator Date 2009-11-30 11:17
Here is my code:
  # In case you use Gosu via RubyGems.
  require 'rubygems'
rescue LoadError
  # In case you don't.

require 'gosu'
require 'texplay'
require 'devil'
#require 'devil/gosu' => no such file to load
puts ::Devil # uninitialized constat Devil
sleep 5

Or did I misunderstand it?

"Admittedly the documentation is presented in quite a wordy/tutorial form but it is nonetheless about 90% complete :) "
And what about the other 10% ? :)
- By banister Date 2009-11-30 17:49

can you tell me the exact system you are running on and also the version of ruby you are using. Could you also pastie the exact error message you get :)

The other 10% will probably be documented soon enough but it includes quite obscure features like L-Systems and such. If you look on the forums here you will probably find mention of those features (L-Systems, blurring/scaling and so on)
- By Wurstinator Date 2009-11-30 19:31
Windows XP SP3
Ruby 1.9.1

DevIL.rb:12:in '<top (required)>': uninitialized constant Devil (NameError)
- By banister Date 2009-12-01 00:06

I've tested it on a windows system running both 1.8 and 1.9 and Devil works fine.
Without any further evidence I have to assume there is something strange with your setup, esp. since you said chipmunk and rmagick were not working as well.

THere is one other possibility though and that is you have another gem named devil or one of your other gems includes a devil.rb file that is conflicting with the devil gem.
- By Wurstinator Date 2009-12-01 17:59
I reinstalled ruby but it still doesn't work.
How did you did it?
Because there is no one click installer for 1.9.1 I installed 1.8 and copied the 1.9.1 files into the Rubydirecotry.
- By banister Date 2009-12-01 19:56
i wouldn't mix up the 1.8 and 1.9 files.

Instead install 1.9 into a fresh directory c:\ruby191\ for example. Also it's a good idea to keep the 1.8 version of ruby lying around too. You can switch between the two versions by adding/removing directories from the PATH variable
- By Wurstinator Date 2009-12-02 21:00
I installed 1.9.1 now alone but when I called gem update I got this error:

and the same when I try to install a gem...
somehow I made my PC hate Ruby :/
- By banister Date 2009-12-02 21:29
Delete everything associated with ruby, ensure you clear out all your directories, and start again from scratch. Just start with 1.9.1 (Don't bother with 1.8 yet)
- By Wurstinator Date 2009-12-03 17:55
'everything' means the directory and the environment variables right?
It is the same...
- By banister Date 2009-12-03 20:39
well, you should probably ask someone familiar with windows to help you out :) (im a linux user)

What if you just use the one-click-installer and stick with 1.8, everything ok then?
- By Wurstinator Date 2009-12-03 21:59
WIth 1.8 I get 'failed to build gem native extension'
- By banister Date 2009-12-03 22:51
you get that error when trying to install the Devil gem??? rubygems should automatically install the win32 version (which does not require compilation).

If you get any kind of choice of which gem to download then choose the windows one If you do not get a choice, then something is screwy and
you'll possibly need to manually download/install this gem:

Follow the same method you did with the ruby-opengl gem.
- By Wurstinator Date 2009-12-04 05:36
No, I get the error when I try to update the gems (gem update)
- By Wurstinator Date 2009-12-08 16:42
Seems like the newest posts have been deleted...
I forgot the command to install a windows version
(gem install gosu --mswin32 or something like that)
could you write it down again? :)
- By Trebor777 Date 2009-12-09 15:17
gem install blablabla --platform=mswin32

to know more about gem:

gem --help, or gem --help install for more detailled information on install... for example.
- By Wurstinator Date 2009-12-11 16:45
Thanks again :)
Up Topic Gosu / Gosu Exchange / Problems with gems

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill