Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Mysterious LoadError
- - By SPK Date 2013-05-04 15:22

I never paid attention to the following error, but I got curious why it happens, because it happens everytime. No matter the environment (Though I didn't try it on Windows).
Each time I launch my game I get the following error:
Exception `LoadError' at /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36 - cannot load such file -- gosu

I know that it doesn't affect my game at all, but I still want to know if it's possible to get rid of it. :)
Parent - - By jlnr (dev) Date 2013-05-05 00:42
Are you using ruby -d? Do you get the same error for other gems too? Maybe an exception is being raised and caught internally when Rubygems loads something.
Parent - - By SPK Date 2013-05-05 07:48
Yes, -w -d are my interpreter arguments.
And as of yesterday my game also uses TexPlay - same error. 

I guess there's no other way than to tolerate the error?
Parent - By jlnr (dev) Date 2013-05-05 09:18
I doubt it. I gave up on -d for similar reasons - third-party is often written without -d in mind and there's no way to disable all the warnings that result from it.
Up Topic Gosu / Gosu Exchange / Mysterious LoadError

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill