Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Extending Gosu / Compiled Chipmunk files
- By bentglasstube Date 2009-02-11 08:22 Edited 2009-02-11 16:56
This one works for me using the latest ruby one-click installer (the mingw compiled version). It will not work with the older MS compiled versions of ruby afaik.  I have it in C:\Ruby18\lib\ruby\site_ruby\1.8\i386-msvcrt\  I am not terribly good with compiling things in this fashion so ymmv. Hope this helps.


I realize now that the version of ruby I have installed is not the one easily found by searching google for "ruby one-click installer" so here is a link to the version I am using: and the article discussing its existence:  In any case this should (theoretically) work for anyone who has the linked version of ruby installed.

Second Edit:

I got to another computer to test out the file on a fresh ruby install and it worked perfectly for me.  Here are the steps I took to get it working:

* Install ruby from (make sure you uninstall any old versions of ruby you might have)
* Add C:\Ruby18\bin to your PATH variable (the installer unfortunately doesn't do this for you)
* Install gosu via gem install gosu --platform=mswin32
* Download (attached) and throw it in C:\Ruby18\lib\ruby\site_ruby\1.8\i386-msvcrt\

I'm not really sure if that path needs to be exact for the last step but that's where it installed when I compiled it and I don't really know if there is a better place for it so I leave it there and it works.  If anyone knows better about the ruby inclusion directory hierarchy and has a better idea where to put it or how this could be packaged up nicely, listen to them instead of me.
Attachment: (0B)
- By jlnr (dev) Date 2009-02-11 19:34 Edited 2009-02-11 19:37
Works just fine with my One-Click Ruby (#26), so I'll link this thread from the relevant wiki pages :)

Also, I attached a Universal bundle for OS X.
Attachment: chipmunk.bundle (0B)
- By bentglasstube Date 2009-02-13 17:32
Rather than having to copy the file to an arbitrary directory, I figured out how to put it in a gem.  Download this and do gem install chipmunk --local and it should sort everything out for you.
- By ramenudle Date 2009-02-20 03:56
So these were compiled solely for Windows?

I've been trying to get ruby chipmunk and gosu working on this Ubuntu box for a while tonight but have failed miserably so far, and have no gem-building knowledge...
- By jlnr (dev) Date 2009-02-20 13:30
Never tried this on Ubuntu, but on OS X you have to go into the ruby directory of the Chipmunk source bundle and run 'ruby extconf.rb', then 'make'. That should give you a file that you can move around and require from your Ruby scripts.
- By ramenudle Date 2009-02-20 21:54
Yeah, I downloaded the actual Chipmunk source code and ran extconf.rb / make...I'd prefer to have a gem, but using the shared lib isn't a problem.
- By jlnr (dev) Date 2009-06-28 18:45
Since Chipmunk is still progressing and the libraries posted here are already outdated, one pragmatic piece of advice is to extract the chipmunk.dll (or chipmunk.bundle) file from this game's trial:

(Kudos to ippa @ #gosu for the hint ;))

Will work with Ruby 1.8 only, but at least it's probably stable. In any case, it is more recent than the 4.10 version linked from the Chipmunk main site, and I couldn't figure out how to build the Ruby extension from SVN on a Mac.

Also, it looks like a nice indie title :)
- By aimjiel Date 2009-08-24 17:39
I am new, and unsure if this should really be here, but, for those of you on linux having trouble with chipmunk, here is a gem and .so compiled on ubuntu jack.

And a compressed version, in case I fudged the gem packaging

I hope this helps.
- By AmIMeYet Date 2009-08-25 12:56 Edited 2009-08-25 13:00
If we're adding our own binaries:

Chipmunk 4.1.0, Ruby 1.9, Ubuntu 9.4 (basically ChipmunkLatest.tgz, patched for Ruby 1.9 (diff))
Attachment: (0B)
Attachment: diff.txt (0B)
- By jlnr (dev) Date 2009-08-25 14:16
Nice work :)
- By banister Date 2009-10-04 19:49
hey i hadn't seen this. could you do a bundle for 1.9 too ? :) then i'll just stick it in the gem and the horror is over...? :)
- By Wurstinator Date 2009-12-10 20:53
Could you please reupload the The forum change destroyed all attachments I think.
- By banister Date 2009-12-11 01:57
Wurst, why not just use the gem?
- By Wurstinator Date 2009-12-11 16:46
With a gem it always tells me, that
is missing.
- By banister Date 2009-12-11 17:02 Edited 2009-12-11 17:19
God knows man, your system seems to have a lot of troubles with a lot of things related to ruby hehe :) are you on a 64 bit system?
- - By Wurstinator Date 2009-12-12 10:43
No, I am using XP 32 bit.
Chipmunk is the only gem that makes problems yet. All others worked fine :/
Parent - - By ? Date 2010-11-07 23:06
Since this thread is still being referenced - chipmunk can now be installed in most systems, including Linux and OSX with gem install chipmunk. I'll try it on win 64 later.
Parent - - By banister Date 2010-11-08 01:16
it will only work on win64 with the rubyinstaller devkit, since the platform gems for windows are 32 bit only
Parent - - By RavensKrag Date 2010-11-08 03:33
Is there any chance of getting a 64 bit gem built? It doesn't really bother me, as I suppose I can just tell people to install the devkit when they install ruby.  However, just though I'd ask.
Parent - By banister Date 2010-11-08 05:43
sure, if there's anyone with a win64 system, i can give instructions how to build a 64 bit gem and push it
Up Topic Gosu / Extending Gosu / Compiled Chipmunk files

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill