Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Error with (Linux)
- - By LuisMartiZa Date 2012-04-28 15:38
Hi i'm Luis!!

After compiling Gosu and files of the game, I get the desired executable. The problem is now, because when I run the program, console throw the following error:

. / program: error while loading shared libraries: can not open shared object file: No such file or directory

If I understand, the problem is to load the library, ... I go to gosu/ lib and the file is there too I'll usr/local/lib and is also there.

I have enough hours gosu deleting files, compiling again ... so I do not know if I touched something and screwed.
As compiled Gosu says explains on its website:

. / configure
sudo make install

Parent - - By Jamer Date 2012-04-29 06:25
Hello Luis,

Linking errors on Linux are tricky. I'm not really sure why such a thing would happen, but here are a few sanity checks you can do:

Run ldd ./program and make sure each line has a => in it. A missing => means the linker is having trouble with that library. It could be that depends on a library that it can't find.

Another possibility is to run ldconfig -p | grep gosu so make sure your linker has libgosu registered! If it doesn't, run 'ldconfig' and try again.

Parent - - By LuisMartiZa Date 2012-05-02 20:37
Thanks Jamer!!

Finally i run ldconfig and it compile!!
Parent - By Jamer Date 2012-05-04 20:41
Glad to be of assistance!
Up Topic Gosu / Gosu Exchange / Error with (Linux)

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill