Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Unable to run a test code on a fresh install
- - By ? Date 2010-11-12 14:13
(I'll figure out a login soon)

I'm posting to hopefully get a little more attention to a fresh install problem I'm having:

Rough paste:

I'm trying to install on a fresh Lubuntu 10.10 install. Everything installed without issue, but trying to run simple gosu code:

The code I'm trying to run is:

#!/usr/bin/env ruby
require 'rubygems'
require 'gosu'

class MyWindow < Gosu::Window
  def initialize
    super(640, 480, false, 20)
    self.caption = 'Hello World!'

w =

... gives me:

./gosu.rb:5: uninitialized constant Gosu (NameError)
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require'
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
        from ./gosu.rb:3

gem list shows gosu (and only gosu). However, when searching (find | grep -i gosu in various root directories) I cannot find any files or directories with the name gosu in them.

/usr/local/lib/site_ruby/1.8/i686-linux is empty.

/usr/lib/ruby/1.8/rubygems has some stuff, but nothing gosu-related.

I've been searching for a good hour and I've experimented a bunch, including uninstalling and reinstalling rubygems and gosu, but nothing has changed this error message.

Since someone using Ubuntu 10.10 has edited this article, it must be possible to get this working on a fresh install. I'm just not sure what I'm doing wrong.
Parent - By jlnr (dev) Date 2010-11-12 14:50
My reply from the wiki:

> I tried it on a brand-new install of Ubuntu 10.10 (not Lubuntu) and everything worked fine. As far as I know all the gems are in /var/lib/ruby or /var/ruby/ or something like that on standard Ubuntu. You can try another binary gem (say texplay) to compare.

If you can find an answer here, I will mirror it back to the wiki too because this is where most people with Linux trouble end up.
Up Topic Gosu / Gosu Exchange / Unable to run a test code on a fresh install

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill