Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Slight Problem with transform
- - By RavensKrag Date 2010-09-24 06:48
In the ruby version of Gosu, if I require 'gosu' then try to call Gosu.transform(-x,-y), the function is evidently defined, but I get a window that's just black, regardless of what parameters I pass to the method.  However, if I also include Gosu, I can call transform(-x,-y) and it works fine.

Is this a limitation of the way Gosu is built, or can you change it so I can call Gosu.transform() ?
Parent - - By jlnr (dev) Date 2010-09-24 07:36
I can and will change it later, for now the only supported form of calling transform is Window#transform. In fact, I have no idea why Gosu.transform is defined at all right now :)
Parent - By RavensKrag Date 2010-09-24 17:59
Ah crud, sorry just realized that transform and translate are not the same thing >.<

To clarify, I was calling translate(-x,-y) and was ending up with a black screen.  Using both require and include solved this problem.  However, I just removed the include, tried to explicitly call self.translate() and it worked.  Then, just now, I removed the explicit self and now it works fine o_O so strange...
Up Topic Gosu / Gosu Exchange / Slight Problem with transform

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill