Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Showcase / the light at the end of the tunnel
- By ippa Date 2009-12-14 09:50 Edited 2009-12-18 10:37
My gosu entry for Ludum Dare #16, spent tops 5 hours on this but it turned out pretty decent.
I think ppl will find it was worth 5 minutes of their lives once they played it through.

~~~ the light at the end of the tunnel
A Ludum Dare #16 entry by ippa

~~~ download
Mac: comming soon, right jlnr? :)

~~~ play from source
Ruby 1.9.1 - download from
Rubygems "opengl", "gosu", "texplay" and "chingu"  - gem install <gemname>

... Oh, also tried to push our Ruby, Gosu etc in my post mortem:
- By ippa Date 2009-12-14 16:03
Looking @ .. I got some ideas. First off, you might wanna submit a square image as primary thumbnail + zoom it in.

I turned into .. in the first you just see some blurry red, in the second you get a sense of the player etc. And the second takes up more real estate in the list :p.

Another thing... if you name your game a bit smart, starting with "." or numbers,  you'll get highest up, maybe not the most honest thing to do oh well. Just noticing that's how they sort.
- By phelps.db Date 2009-12-15 00:16
It appears that no such gem "opengl" exists.

I tried to gem install ruby-opengl to see if that was the same thing, but to no avail, for it tells me that it fails to build the native gem extensions and then proceeds to spit out a lecture-length error. I'm on Ubuntu 9.10 with ruby 1.9.1, if that says anything to help the problem, although it did not work with ruby 1.8.7 either.
- By jlnr (dev) Date 2009-12-15 08:25
Yeah, for some reason the gem is called "ruby-opengl" :)

I guess your rubygems version is recent? This gem has a tendency to always require the latest version.
- By banister Date 2009-12-15 11:27
@phelps, im on ubuntu and i do not get that error, can you pastie the error msg? my immediate guess is you do not have the opengl headers installed.
- By ippa Date 2009-12-15 11:29
damn, didn't know the open gl gem would cause so much trouble ..

jlrn: retrofy in next release? *puppyeyes*
- By phelps.db Date 2009-12-15 23:17
The details of the error can be found here.

When I used "gem -v" it returned 1.3.1

As an aside, when I tried to play selene, banister, it spat out a segmentation fault in texplay of some sort.

Geez. None of the games seem to be working for me.
- By banister Date 2009-12-16 05:46
yeah, the segfault in texplay only happens on some versions of linux and should be fixed when 0.7.16 gosu is released.

the error in ruby-opengl is due to this: "/usr/bin/ld: cannot find -lruby". On my system the library is called -lruby1.8 and -lruby1.9. I got the same error when installing the ruby-opengl gem and i fixed it by creating a symlink from to and reinstalling the gem, a similar
thing can be done for ruby 1.9
- By banister Date 2009-12-16 06:06
IMO if you want to play ippa's game it's best to dl the windows version and run it in WINE (since tp will still segfault on your system so you wont be able to play it from source)
- By ippa Date 2009-12-18 10:30
A Ludum Dare dude (sfernald) hacked up some new levels to my game .. I just played through it, hard but fun =). He actually used the game engine better then I did.

Blogged about it @  .. also includes some ideas for a sequel.

Or just DL it:
Win32 exe:
Up Topic Gosu / Gosu Showcase / the light at the end of the tunnel

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill