Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Problem with installing gosu on Ubuntu 14.04
- - By Enk Date 2014-11-23 20:07

I am quite new to Ruby and I am trying to install gosu.
I have followed the instructions from:
as well as the more detailed forum post:

But when I run gem install gosu I get this error message every time. I also tried with sudo gem install gosu

Building native extensions.  This could take a while...
ERROR:  Error installing gosu:
  ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb
The Gosu gem requires some libraries to be installed system-wide.
See the following site for a list:
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in require': cannot load such file -- mkmf (LoadError)
  from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
  from extconf.rb:63:in `<main>'

Gem files will remain installed in /var/lib/gems/1.9.1/gems/gosu-0.8.5 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/gosu-0.8.5/ext/gosu/gem_make.out

All I can figure out from this is that I still lack a few libraries. And I looked into the file custom_require.rb but it didn't contain any list of missing libraries.
So I'm lost. What is wrong?

My computer is running Ubuntu 14.04. And rvm is installed with ruby-1.9.2-p330 and ruby-2.1.5

Thanks for any help!
Parent - - By jlnr (dev) Date 2014-11-24 06:50
The error message is coming from Ubuntu's own Ruby, because you have used sudo gem install gosu. (Installation fails because you haven't installed the ruby-dev package, but that's okay since you didn't intend to use system Ruby anyway.)

What is the error message if you use gem install gosu instead?
Parent - - By Enk Date 2014-11-24 11:23
I don't remember exactly the error message but it was very similar.
And today when I typed in gem install gosu it worked.
Gosu installed without problems.
Parent - By jlnr (dev) Date 2014-11-24 13:15
Good to hear that :)
Up Topic Gosu / Gosu Exchange / Problem with installing gosu on Ubuntu 14.04

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill