Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Gosu 0.8.5 on Debian Wheezy
- - By BlueScope Date 2014-11-10 21:25
So, I've tried to install Ruby and Gosu on my Debian installation, with no such luck so far. I tried catching up with the required packages, installed ruby-dev and gems, then tried to install the gosu gem, with this result (includes build output).

As a heads-up, I'm not much of an expert on the matter, so this error report means about nothing to me. I did read a few threads about libsdl2 causing problems with gosu 0.8.x, and i see sdl2, especially sdl2_ttf, all over that report. Now I made sure the respective packages, or what I think they should be, are installed, being:

libsdl2-dev-2.0-0 (from debian backports)

Now the last two on the list seem to be for libsdl 1.2, however I can't seem to find a libsdl2-ttf or libsdl2-ttf-dev anywhere, backports or regular, or anything similar. Am I overlooking something?

Thanks in advance for any pointers!
Parent - - By jlnr (dev) Date 2014-11-11 05:01
Hm, looks like you are right:

Not sure what to do about this. You could request a back-port, or compile it yourself, see the comments here on the top answer:

I can't make Gosu work with SDL 1.2, sadly. It might be easier to "just" upgrade your Debian system ;)
Parent - By BlueScope Date 2014-11-11 11:28
My main problem here is that I'm really not all that expert-ey on the matter. I will, however, look into it tonight and keep this thread updated if I find anything helpful.
Thanks for the link in any case, let's hope I'll know how to use it :D
Up Topic Gosu / Gosu Exchange / Gosu 0.8.5 on Debian Wheezy

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill