Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Using releasy
- - By Hyang Date 2014-09-22 02:59
I had installed releasy so I could export my project, and I copied and edited a ruby file that should do the trick, but when I run it, the command prompt told me that there was a load error for the 'bundler'. I'll post my code, but I think it may have to do with the gem installed.

  require 'rubygems'
  require 'gosu'
  require 'bundler/setup' # Releasy requires require

that your application uses bundler.
  require 'releasy'

  #<<< do
    name "Pong"
    version "0.0.5"
    verbose # Can be removed if you don't want to see

all build messages.

    executable "c:/ruby193/Pong.rb"
    files "c:\ruby193\pong.rb", "c:\ruby193\data

\music2.ogg" , "c:\ruby193\data\hit.ogg", "c:

\ruby193\data\wall.ogg", "c:\ruby193\data\pongcars.ogg",

"c:\ruby193\data\victory.ogg", "c:\ruby193\data

    exclude_encoding # Applications that don't use

advanced encoding (e.g. Japanese characters) can save

build size with this.

    add_deploy :local # Only deploy locally.
Parent - By jahmaican Date 2014-09-22 06:16 Edited 2014-09-22 06:36
You might not have bundler gem, or have multiple versions of Ruby installed (this might cause some chaos), or something.

Just try and remove require 'bundler/setup' line. Says it's required but I believe it actually isn't.
Parent - By shawn42 Date 2014-09-22 21:18
It depends on how you're running ruby. To use Releasy, you should use bundler and have a Gemfile with all the versions of the gems that you want to use. Bundler will track all the dependencies for you and include them in your app. If you have your Gemfile all setup, you should also ensure that you have the bundler gem installed via "gem install bundler". If you're still stuck, post your files and the error  somewhere and we can try to take a look.

Hope that helps.
- - By Hyang Date 2014-09-23 02:42
I removed the require bundler line, but then the command prompt tells me that there are issues in my block, argument errors, wrong number and the like.
I installed bundler and tried running the original code, but it tells me the same thing it did at first.
So should I uninstall ruby and make sure to only add certain gems or something? It took me a really long time to actually get a ruby that would work with my computer, so I'd rather not do that if I could.
Parent - - By jlnr (dev) Date 2014-09-23 10:22
Can't you just run gem install bundler to install bundler? That seems like the obvious solution :)
Parent - - By Hyang Date 2014-09-24 02:34
I already did. When I try running the code that requires bundler, it tells me there are errors like they couldn't find the components or something.
Parent - - By RavensKrag Date 2014-09-29 15:18
Maybe you need to add the bundler executables to your PATH?
I'm not really sure how to do that on Windows, but I think the other people here should be able to help you with that part.

Have you tried running bundle in a terminal, just to make sure that everything is working correctly?
Parent - - By Hyang Date 2014-09-30 03:21
By terminal, do you mean like inside the command prompt?
Parent - - By RavensKrag Date 2014-09-30 03:48
oh, yeah.

Sorry, sometimes I forget the Windows terminology for things.
Parent - By Hyang Date 2014-10-01 02:37
Well, yeah. I've already done that, and that's where I get all my 'incorrect sum' or the like.
Should I reinstall releasy or bundler?
Up Topic Gosu / Gosu Exchange / Using releasy

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill