Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / error with require 'gosu' (windows 7)
- - By Daidalos Date 2012-05-09 15:54
Hi, I'm back on Ruby/Gosu since a few days and have encounter some errors (like with Open GL).
To resolve them, I had installed latest versions of Open Gl and realtek drivers, as latestessts of Ruby and Gosu, with the gem. it worked fined, except for the sound that stuttered. On the forum I encountered a subject close to my problem that says to try version 7.33 (the latest before OpenAL).
I downloaded this version and manually installed the file Gosu.lib in the directory Ruby1.9.3\lib\ruby\site_ruby\1.9.1\i386-msvcrt
But since then, the command line : require 'gosu' doesn't work anymore.
I tried 'gosu', '', '', it always returned me : C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in require': cannot load such file -- gosu (LoadError)
  from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
  from main.rb:1:in `<main>'

I wondered if it was a path problem and asked for $LOAD_PATH, but the path to i386-msvcrt was in the list.
I can't think of an other solution and am tired to search on the web. Can someone please help me ?
Parent - - By jlnr (dev) Date 2012-05-10 03:44
Gosu.lib is for C++, not Ruby. To install version 0.7.33 cleanly, use gem install gosu -v 0.7.33. You should probably run gem uninstall gosu first to remove every installed version of Gosu first, just to make sure your code will load the right one later.
Parent - By Daidalos Date 2012-05-10 05:42
Ok ! Done and works fine (I didn't know how to install ancient version of a gem... maybe should I go looking for tutos that tells how to use the console, and gem)! The music is now playing correctly as well, so it seems you were right in the other topic I mentioned, when you thought the stuttering was a problem with OpenAL. Thank you Julian !
Up Topic Gosu / Gosu Exchange / error with require 'gosu' (windows 7)

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill