Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Showcase / Wrath: Appease or Die!
1 2 Previous Next  
Parent - By bestguigui Date 2011-07-04 16:21
Yeah, maybe a little tutorial would have helped. I never used IRC. I tried to connect to #gosu channel using the link provided on libgosu homepage, but there is no one there.
Parent - - By jlnr (dev) Date 2011-07-05 10:41 Edited 2011-07-05 10:54
The intended combination would be to use KbA for the controls, but to display button_id_to_char(KbA) to the user (in case their 'should-be-A' key has a different name).

I guess that :a as the key name should still mean KbA in Chingu, but you should have a different hash for user display. That would solve the problem.
Parent - - By RavensKrag Date 2011-07-06 19:18
Does this work on linux as well? IIRC, the linux keys were not returning the expected values.
Parent - - By jlnr (dev) Date 2011-07-07 08:25
Right, if you have any idea how to fix this please let me know. On Linux, KbA is always 'a'. :(
Parent - By Spooner Date 2011-07-08 10:51
Well, I've implemented it in my controls settings and it should work where gosu works then :)
Parent - - By ml Date 2013-08-24 22:42
Hi Spooner. Since I first start trying out Gosu, I've been trying to load a few games by yourself and lol_o2 to little avail. One time, a number of months ago, I was able to get Wrath to load up and work on my brother's mac, and we played several rounds - it can get very competitive! I am still trying to figure how to run the game straight from Ruby (i.e. not the .exe or .app) on Linux (Ubuntu 12.04).

A few months ago I didn't have enough tools in my toolbelt to make try to figure this out. But now that I have a little bit better understanding about a few things, I think I'm ready to try again.

I have made it as far as the game window popping up before getting an error. When I execute "ruby wrath.rbw", I get a bunch of DEBUG information in terminal, and then I get the following:

[2013-08-24 16:37:52 -0600  INFO] Opened window at 768x480 (X4 zoom)
[2013-08-24 16:37:52 -0600  INFO] Reading sound settings
[2013-08-24 16:37:53 -0600  INFO] Preloaded priest icons in 0.570853882 seconds
[2013-08-24 16:37:53 -0600  INFO] Reading achievement/stats
[2013-08-24 16:37:53 -0600 DEBUG] Loaded settings from '/home/matias/.wrath_spooner/config/achievements.yml': {}
/.rvm/gems/ruby-1.9.3-p362@sampleGemset/gems/gosu-0.7.48/lib/gosu/swig_patches.rb:44: stack level too deep (SystemStackError)

Do you have any suggestions?
Best wishes,
Parent - - By Spooner Date 2013-08-24 22:44
Try using "bundle install" and then "bundle exec ruby bin/wrath.rbw" to start it up. That will prevent it from using a "bad" (read: unsupported) version of Gosu.

EDIT: Wrath runs correctly on my machine with Gosu 0.7.46 via bundler.
Parent - - By ml Date 2013-08-24 22:56
Wow you're fast! I was using "gosu", "~>0.7.41" in the gemfile, which installed Gosu 0.7.48. I just changed it to "gosu", "0.7.46" and then updated the bundle install and everything.

I am still getting the same thing, including when I run it with "bundle exec". When I execute "bundle list" from the /wrath folder, I get:

Gems included by the bundle:
  * bundler (1.2.3)
  * chingu (0.9rc9)
  * chipmunk (
  * clipboard (0.9.9)
  * ffi (1.0.9)
  * fidgit (0.1.10)
  * gosu (0.7.46)
  * r18n-core (0.4.14)
  * r18n-desktop (0.4.14)
  * texplay (0.4.3)
Parent - By Spooner Date 2013-08-25 00:37
If you are still getting an error in that swig file, I don't really know then. jlnr is the only one who groks swig on any level. Sorry!
Parent - - By ml Date 2013-08-24 23:17
I just checked and my Linux system is 32-bit. Not sure if this could have something to do with it?
Parent - - By Spooner Date 2013-08-25 00:33
I can't imagine that would be a significant issue.
Parent - By ml Date 2013-08-25 03:35
Thanks as always for your help. I'll keep chipping away at it....
- - By Jwosty Date 2011-10-29 03:36
I saw this a few moths ago; I just had so much fun with it that I forgot to post. Oh, the irony :P
This game is simply outstanding. I played it with my brother and a few of my cousins (as soon as I found it), and we had so much acting like idiots in-game :D
I would say, this is one of the most professional-looking Gosu games that I have played (though unfortunatley we can't play There's No Place Like Homeless!!! haha), honestly. I just love it.
Parent - By ml Date 2013-08-24 22:45
Same thing happened to me, more or less. I played it several months ago on my brother's computer, and it is the most advanced Gosu game that I have been able to successfully load and try out (though still not working for me on Linux....)

I concur that it is outstanding!
- By ickylevel Date 2012-02-26 14:46
Release it on more forum.
Up Topic Gosu / Gosu Showcase / Wrath: Appease or Die!
1 2 Previous Next  

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill