Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Showcase / Super Duper Mario
- - By lol_o2 Date 2010-03-07 14:35 Edited 2017-06-19 19:41
My Mario clone which was going to be The Ultimate Mario Fan Game. Currently abandoned. More infos in this subject:


All of the links died, but you can get the game here:
Parent - - By lol_o2 Date 2010-07-05 18:45
Game updated.

And a small thing to TexPlay. Maybe I played on a small older version, but it makes error with this lights/shadows. It's just a drawing error. Game sometimes is getting stuck in dark room. Same while initializing editor (it uses image filling).
Parent - By banister Date 2010-07-05 23:35 Edited 2010-07-06 00:43
can you isolate the error and give me a code sample to work with? i'll look into it

(but at a guess, are you saying that the flood fill code goes into an infinite loop?)

EDIT: as a temporary work around you may be able to use :dest_select in combination with filled rectangles to get the effect you want. It's also many times faster than a flood fill.

@img.rect x1, y1, x2, y2, :fill => true, :color => :red, :dest_select => @img.get_pixel x1, y1
Parent - By stathmk Date 2010-12-04 00:15
You might like Mario Forever.  I’ve made my own levels from Mario Worker, and both are from

I’m trying to learn the basics of Ruby.  We’re trying to get Rubystein from working so that I can put it on my Wolfenstein web page with instructions.  Please post on or with basic step-by-step instructions for running a Ruby game.  I get a problem when I type “gem install gosu” or “ruby wolf3d.rb” in the window.  I’d like to know how to run this Mario game too!
Parent - - By ches Date 2011-10-29 22:32
Hi, I'm just taking my first look at Gosu and this looked like a fun project for sample code. I see that you just updated the download here recently -- is there a non-Windows initialization script of some kind, or a makefile? Thanks :-)
Parent - - By lol_o2 Date 2011-10-30 07:17
Parent - By ches Date 2011-11-06 16:36
Great, thanks for the quick reply! The link wouldn't work the first few times I tried it, but coming back after a few days I've gotten it and am having a play with it now :-)
Parent - - By erisdiscord Date 2011-12-08 02:41
Foo. I wanted to check this out because it was featured yesterday and I guess I missed the original post. But now I see the download link (and the one for the init script too, since I'm on Mac) has gone 403. Any chance you could reupload elsewhere?

Sorry in advance for practicing thread necromancy.
Parent - By Jwosty Date 2011-12-08 04:14
Yeah, I'm getting that too. I wanna try this too! xP
Parent - - By lol_o2 Date 2011-12-08 14:24
There's a temporary problem with the host. The game should be downloadable in few days.

And BTW, I added the initialization script to main file.
Parent - By erisdiscord Date 2011-12-09 00:26
Good enough, thanks! C:
Parent - By Jwosty Date 2011-12-09 02:24
- By ippa Date 2010-03-07 20:46
I see you have the very same problems with the opengl gem that I have.. what are you using it for in your mario clone?
- By ippa Date 2010-03-07 20:59
hey supercute game, seems like you've worked on a lot of details as well. I bumped into 2 possible bugs..  When I chose start game.. and then inside the profile menu I create a new one, but then I can't choose it to start with that profile, only back works there. Tried creating some different profiles but same thing.

Then I tried the custom levels, which worked well. When trying out the factory level I get FPS drops though.. 30-40 etc.. and I'm on a shiny new Core i5 machine.

Great stuff in either case, like how it feels like a real big game, with menus, profiles, a lot of music/sound and even a level editor.
- By banister Date 2010-03-07 21:25
A lot of potential here, very polished.
- By lol_o2 Date 2010-03-08 12:49
I know about the slow FPS. Maybe someone know how to make it faster?
The profiles are not working now. Enjoy these three levels or make your own.
And I want to use OpenGL to make dynamic lights... You can see a function in editor to make "dark room". But it's and idea for later.
- By AmIMeYet Date 2010-03-08 14:51
I can't run it, because it crashes when loading files. This is because, just like in your previous game, you keep using capital letters where you should not. You see, most operating systems, except for those on windows, are very specific with the naming of their files.

For example, to load the image 'gfx/backgrounds/Arena.png', you set it to load 'gfx/Backgrounds/Arena.png', so basically you incorrectly capitalize 'Backgrounds'. Any chance you can fix this? (a quite tedious job)
- By lol_o2 Date 2010-03-08 15:07
If it crashes at backgrounds, open data/scripts/menus.rb (by any text editor), go to line 33 and change 'Img["Backgrounds...' . I hope that only directory names cannot be capitalized.
It will be changed at next update.
- By AmIMeYet Date 2010-03-08 19:23

> If it crashes at backgrounds, open
> data/scripts/menus.rb (by any text editor), go to
> line 33 and change 'Img["Backgrounds...' . I hope
> that only directory names cannot be capitalized.
> It will be changed at next update.

Well that fixed that error, but unfortunately, everything needs to be correctly capitalized.. :(
- By lol_o2 Date 2010-03-08 19:38
If it crashes still in the same place, change {a} to {a.downcase} and the same in line 146. If it's not problem with loading, but with NAMES OF FILES, I will need to change 130 of them...
- By AmIMeYet Date 2010-03-08 20:49
simply setting to loading to downcase won't work, because some files have uppercase letters in the names. So yes, it's either changing 130 file/directory names, or editing the filenames that you load. Sorry for that
- By phelps.db Date 2010-03-09 01:49
Sounds like fun... too bad I can't run it because texplay segfaults for every single gosu game that touches it over here   |^(

Really wanted to check out that level editor, though.
- By lol_o2 Date 2010-03-09 12:43
OK, I have solved the problem with names:
Download it and run downcase_utility.rb in game's directory. Mlv files replace in data/own_levels,   specjal.rb in data/scripts    and nine.ttf in fonts. Write here all files which I forgot.
- By banister Date 2010-03-09 13:41
re: texplay segfaulting

haha, you're running on a linux system right? :) yeah, i really should roll out a patch for that (i know exactly the problem).

Hardly any people seem to mention this difficulty though and so i keep forgetting about it :/
- By jlnr (dev) Date 2010-03-09 14:21
Does not work for me on OS X. May be related to the fact that you use multiple windows which is not really well supported :( Is there a way to skip the first?
- By AmIMeYet Date 2010-03-09 14:49

> Download it and run downcase_utility.rb in game's
> directory. Mlv files replace in data/own_levels,  
> specjal.rb in data/scripts    and nine.ttf in
> fonts.

Awesome ruby fix!

But just like your previous game, I suck at it.. ;)
The first and last level had a fine FPS, but second one got 4 to 7 FPS, lol (but that's okay, it's a laptop)
- By lol_o2 Date 2010-03-09 19:49
To skip the first window, open the main file (Super_Duper_Mario.rb) and change line 99 to $
- By banister Date 2010-03-15 21:49
did you figure out the cause of the lag yet?
- By lol_o2 Date 2010-03-16 13:01
All update notes are at the top of this topic (1st post). And it's written, that the game should not lag now.
As I said, a small patch:   Replace it in data/scripts.
- By banister Date 2010-03-16 13:09
out of interest what was causing the lag? congrats on getting rid of it

regarding dynamic lighting, what did you ahve in mind? what kind of thing? im writing something that may provide what you want for a coming release of TP
- By lol_o2 Date 2010-03-16 18:13 Edited 2010-03-16 18:17
The lag was because I used .find method to check map solidify and the game was searching for one from tens of tiles, many times per frame.
Sry, ommision. I wanted dynamic SHADOWS, there was a topic on this forum how to make it in Open GL. I have only idea and I didn't even read it. :)
- By ? Date 2010-03-28 21:47
I would really like to try your game, but it seems your second link for the version with the corrected file names doesnt work. If it isnt too much trouble, would you like to upload a new version?
- By lol_o2 Date 2010-03-29 11:53
??? If you download the game, you should find file named downcase_renamer.rb I tested it and it's working.
- By lol_o2 Date 2010-03-31 12:23
Game updated. All changes at top of topic.
- By banister Date 2010-03-31 12:37
what errors do you get when loading images on 1.9?
- By lol_o2 Date 2010-03-31 13:16
When loading 640x480 images on XP it makes Ruby backtrace error. But it's only when loading more than one.
- By banister Date 2010-03-31 19:00
can you post the full error on here? :) im curious
- By lol_o2 Date 2010-04-01 07:57
I can't because I don't have Windows XP. I tested it in school with version compiled by Ocra (the same you can download).
- By lol_o2 Date 2010-04-24 18:33
Game updated, go to top of topic.

And to this lights: I'm now trying with different effect than I wanted, but I have problem with speed. To fill screen with black, filling blank image is to slow, but works even fine. To make lights I'm using draw function (rect,circle) with no alpha, but with all, FPS drops to 20.
- By banister Date 2010-04-24 22:18
show code with lights
- By lol_o2 Date 2010-04-25 15:28 Edited 2010-04-25 15:41
- By lol_o2 Date 2010-05-23 09:00
Game updated, go to top of topic.
- By banister Date 2010-05-23 10:22

tell us about your lighting effects and how they work :)
- By ? Date 2010-05-25 10:50
Hello everybody, it's my first post, but I'm following the gosu project since some months ago. I've just tried to run this game (it looks awesome :D ), but that's what I get:

tony@polik-ubu8:~/Download/Super Duper Mario - demo5$ ruby1.9.1 super_duper_mario.rb
/var/lib/gems/1.9.1/gems/texplay-0.2.800/lib/texplay.rb:107:in initialize': Cannot open file gfx/background.png (RuntimeError)
  from /var/lib/gems/1.9.1/gems/texplay-0.2.800/lib/texplay.rb:107:in
  from /var/lib/gems/1.9.1/gems/texplay-0.2.800/lib/texplay.rb:107:in new'
  from /home/tony/Download/Super Duper Mario - demo5/data/scripts/specjal.rb:18:in
  from /home/tony/Download/Super Duper Mario - demo5/data/scripts/menus.rb:48:in block in update'
  from /home/tony/Download/Super Duper Mario - demo5/data/scripts/menus.rb:48:in
  from /home/tony/Download/Super Duper Mario - demo5/data/scripts/menus.rb:48:in update'
  from super_duper_mario.rb:46:in
  from super_duper_mario.rb:101:in show'
  from super_duper_mario.rb:101:in

Cannot open file gfx/background.png ? o_o
I'm not a total newbie in Ruby, but this project is quite big so I can't figure out by myself what the real problem is.

Maybe someone has the solution? :)

Thanks a lot (please forgive my english)
- By jlnr (dev) Date 2010-05-25 14:17
Well, you can see if there is ans Dir.chdir or something like that happening. Or you can grep for the line loading background.png, then do "p Dir.pwd" right before that. Having a wrong current directory is the only explanation I can find for not being able to open a harmless image file.
- By tonypolik Date 2010-05-26 06:12

the problem is that there's not "background.png" file in the gfx directory.

Line 48 in menu.rb is
ary.each{|a| Img["backgrounds/#{a}".chop.chop.chop.chop]}

and line 18 in specjal.rb is
@@images[name] =$screen, "gfx/"+name.downcase+".png")

Those four .chop just delete the last 4 characters in the string, i would consider a safer alternative; i replaced line 48 with
ary.each{|a| Img["backgrounds/#{a}".chomp(File.extname(a))]}
and now I get this error

Cannot open file gfx/backgrounds/...png (RuntimeError)

So, basically, the problem is that the program try to process the "file" '..' :)
menus.rb is full of
ary.delete_at(0), but at position 0 there are not '.' and '..', at least for me .-.
So i replaced them with
and everyhting seems to work fine.

If someone has the same problem:
go to menus.rb, and replace every
after that, replace every

Thanks for the answer, for the game and for the gosu framework :) bye!
- By kyonides Date 2010-05-26 23:11
I guess it'd be better to delete those two entries like this...

ary -= ['.', '..'] #=> ['a.png', 'b.png', 'c.png']
- By jlnr (dev) Date 2010-05-29 06:00
Took me a while to boot to Windows because it won't run on OS X for some reasons (need to look into those). I always like it when people come up with their own lovable characters :P, but wow that's an awesome clone so far. Does your Ruby 1.9 problem persist? (Not sure when you edited it in)
- By lol_o2 Date 2010-05-29 07:41
I don't know because I don't have Windows XP :) But I think yes.
Up Topic Gosu / Gosu Showcase / Super Duper Mario

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill