Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu News / Gosu 0.8.6 released
- - By jlnr (dev) Date 2014-12-06 20:39
Just another maintenance release:

* Windows: Add support for Ruby 2.1.x
* All: Check SDL 2 return values when creating the Window (helpful when there is no OpenGL capable video driver)

Also, the release process is a little messed up. There have been no 0.8.x source tarballs so far. The new directory structure in 0.8.0 also broke the CMake setup. I'll try to fix these issues and follow up with a working 0.8.6 source tarball. Hopefully that will make it easier to get C++ Gosu into package managers such as Homebrew (see
Parent - - By lol_o2 Date 2014-12-06 21:45
So, I managed to install it and even install Ashton and even successfully run them (wow) and now everything is faster (at least something). Thanks.
Still no x64 though
Parent - By jlnr (dev) Date 2014-12-06 23:00
Thanks for testing and that's great to hear :) The x64 version is a bit more involved. To support a new Ruby version, I only need to extend Gosu a little, and this is now a well-documented process (phew):

For the x64 version, I will also need to hunt down each of Gosu's dependencies in 64-bit. Most libraries offer a precompiled x64 DLL nowadays though, so I'm almost there. :)
Parent - - By jlnr (dev) Date 2014-12-10 19:43
x64 is out now, please let me know if it works as expected. Ruby 2.1.x only.
Parent - - By lol_o2 Date 2014-12-10 20:05
I attached an error message. But my Ruby installation may be broken (I even have to download gems manually :/).
I fixed it by copying directly to lib. And, I can confirm that... it works. Yes, Gosu x64 WORKS AS EXPECTED, good job :)

Parent - By jlnr (dev) Date 2014-12-10 20:25
Cool, good news!

Re: LoadError, I'll wait for a second person to report this error before I look into it...might be my fault :)
Up Topic Gosu / Gosu News / Gosu 0.8.6 released

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill