Not logged inGosu Forums
Forum back to Help Search Register Login
Up Topic Gosu / Gosu Exchange / Ocra and Chipmunk
- - By rremedio Date 2016-09-13 16:54
I'm almost sure this issue didn't happen with older versions of the Chipmunk gen. The process of creating an exe with Ocra is successful, but when I try to run it I get the following message:

Ignoring chipmunk- because its extensions are not built.  Try: gem pristine chipmunk --version

gem pristine chipmunk --version doesn't fix it.

Does anybody know how to make it work?

I made it work with chipmunk-ffi but there were some new problems:

1 - I get a bunch of undesired double/triple hits being handled despite my game checking and handling them (I don't have this problem with the chipmunk gem, but it is no big deal since I can probably fix it in my collision callbacks).
2 - I get runtime errors now and then (can't understand the reason since it appears to be random, with the game behaving differently each time I run it, without code changes. Probably need another .dll for chipmunk?).

It also required me to add some simple functionalities to the Shape classes, which makes me think chipmunk-ffi may be outdated compared to chipmunk gem.

Any ideas?

ps.: I'm using the dreaded Windows 10 Home 64bits with Ruby 2.0.0p576 and Gosu 0.10.8
Parent - - By shawn42 Date 2016-09-13 18:12
Hi there rremedio,

The older versions of the chipmunk gem were cross compiled and published as binaries for Windows. As the only person that has touched maintenance on the chipmunk gem, I dropped the pre-built binaries for version 6. I'd love to add them back in, but I do not have time to do so.  Feel free to file an issue here:  If you or someone else wants to pick up that torch, let me know.

Also, I am the creator of chipmunk-ffi as well (built as a research project into FFI, not really great for games since FFI cannot use static inlines). If you file issues on github, I'll try to help with any errors.
Parent - By rremedio Date 2016-09-13 19:41
I'd like to help, but I don't have too much time myself. Maybe I can look into it (and learn how to do it) later this year.

Thanks for your work in both chipmunk gems!
Parent - - By lol_o2 Date 2016-09-13 19:32
I had a problem that I couldn't make an Ocra executable with Chipmunk. What I did was just copying the file to my project and including it like normal source file. Works with
Parent - By rremedio Date 2016-09-13 19:41
Thanks! It worked like a charm.
Up Topic Gosu / Gosu Exchange / Ocra and Chipmunk

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill